
- 1 - 
 

TK-mini Panel                                                                                                                     ©2015 Tony Kuyper 
 

TK-mini Panel 
A custom panel for Photoshop 

©2015 Tony Kuyper 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
Copyright Notice 
 
The TK-mini panel is copyrighted material (©Tony Kuyper).  You may use the panel 
for your personal work and enjoyment but transfer or sale is prohibited. Thank you 
for respecting the time and effort to produce this information and for showing the 
appropriate consideration for the intellectual property of others.  As always, please 
feel free to contact me if you have questions, comments, or suggestions.   
 
 
 
 
 
 
 
 
 
 

http://goodlight.us/contact.html
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NEW FEATURES 
 
TK-mini panel is a stepping stone for incorporating 16-bit luminosity masks into the 
larger, more-inclusive panel.  There are several new features being tested in this 
panel that will eventually find their way into the larger panel.  
 
1.  "Action-less" actions.  Previous "TK" panels relied on action sets to complete 
the task assigned to each button.  Pressing a button would play an action on 
Photoshop's regular Actions panel.  The mini panel eliminates this reliance on 
external actions to complete tasks.  Instead, the actions have been programmed 
into the panel itself.  When a button is pressed on the mini panel an internal action 
completes the task.  This greatly simplifies installation and keeps Photoshop's 
Actions panel cleaner.   
 
2.  Smart buttons. The buttons on the mini panel contain programmed logic that 
monitor Photoshop to make sure that the task assigned to the button can actually 
be completed.  If the task is not possible under the current conditions, then the 
action programmed into the button will not be attempted.  For example, most 
buttons on the panel remain inactive (don't do anything) until an image is open in 
Photoshop. 
 
3.  "Toggle" buttons.  The monitoring capability has been extended to include 
checking for the effect created by initially pushing a button.  This allows any button 
to become a toggle that switches between different actions.  The action performed 
depends on what the button has already done in addition to the current state of 
things in Photoshop.  These toggle buttons have a "+/-" designation in front of their 
name.  For example, the +/- All Masks button creates all the luminosity masks on 
the Channels panel when it is first pressed and then removes all these masks from 
the Channels panel the next time it is pressed.  
 
4.  16-bit luminosity workflow.  Perhaps the biggest change in this panel is an 
entirely new method for creating luminosity masks.  The original Luminosity Masks 
tutorial and previous actions and panels all contained intermediate steps that 
included 8-bit selections.  The mini panel completely changes this.  There are no 
longer 8-bit steps in the 16-bit workflow.  All luminosity selections in the mini panel 
are created directly from a 16-bit image or mask (see blog post).  While selections 
remain 8-bit (this is hard-wired into Photoshop) the effect of the 16-bit workflow is 
noticeably smoother masks and selections.  Luminosity masks and selections have 
always provided excellent tonal gradation to blend adjustments and brushstrokes 
into the image. The new 16-bit workflow not only makes these gradations even 
smoother, but it also makes them unbreakable.  This blog post has additional 
details and illustrations. 
 
 
 
 
 
 
 

http://goodlight.us/writing/luminositymasks/luminositymasks-1.html
http://goodlight.us/writing/luminositymasks/luminositymasks-1.html
https://tonykuyper.wordpress.com/2015/02/28/how-to-make-16-bit-luminosity-masks/
https://tonykuyper.wordpress.com/2015/05/13/16-bit-luminosity-masks-do-they-make-a-difference/
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VERY IMPORTANT INFORMATION 
 
1.  The actions in the panel are meant to be used in RGB mode.  While some of 
them will work in Lab, Grayscale, and CYMK, the buttons have only been tested in 
RGB mode.  The results in modes other than RGB are not predictable and may lead 
to error messages. 
 
2.  There are two versions of the custom actions panel.  One works in Photoshop 
CS6 and the other in all versions of Photoshop CC.  The panel will NOT install nor 
work in CS4 or earlier versions of Photoshop.  While the panel can be installed in 
Photoshop CS5, there is potentially a bug in the early versions of CS5 that 
generates black-flecked masks with the new 16-bit workflow.  As such, it is 
recommended to NOT use the panel in CS5, though if you have a later version of 
CS5, the bug may be fixed and the panel will work.  For more information on this 
bug, read this Adobe Forum post.  Installation in CS5 is the same as installation in 
CS6 (see directions below). 
 
3.  The Photoshop CC version of the panel looks slightly different than the 
Photoshop CS6 version.  This is the result of a requirement by Adobe to use 
different programs to create extension panels for different versions of Photoshop.  
Both versions have nearly the same layout and mostly work the same.   
 
4.  The panel is locked and will not generate scroll bars.  It can be docked to panel 
bars in Photoshop. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://forums.adobe.com/thread/963251
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INSTALLING THE PANEL 
 
The custom TK-mini panel works in 32- and 64-bit version of Photoshop CS6 and all 
versions of Photoshop CC.  There are different versions of the panel for these 
applications:  one for Photoshop CS6 and another for Photoshop CC (which includes 
Photoshop CC, CC 2014, CC 2015, and subsequent versions).   
 
Installation in Photoshop CS6 
 
NOTE:  Most Photoshop CS6 users are now using the 64-bit version of the 
applications.  As such, the installation instructions are for the 64-bit version of 
Photoshop CS6.  If you are using the 32-bit version of the program (Windows 
users), you'll simply need to locate the correct folder in your directory in "Program 
Files (x86)" 
 
 

1. Close Photoshop.   
2. Locate the "TK" folder in the download as follows:  Download folder > 

"Installation-for-Photoshop-CS6" folder > "TK" folder. 
3. Copy the "TK" folder to the "Panels" folder of the Photoshop CS6 application.  

Do NOT open the "TK" folder and copy what's inside the folder.  Instead, 
copy the entire "TK" folder to the "Panels" folder.  
For Windows, the path to the "Panels" folder is:  "C: > Program Files > 
Adobe > Adobe Photoshop CS6 (64 Bit) > Plug-Ins > Panels"  
For Mac, the pathway to the "Panels" folder is:  Macintosh HD > Applications 
> Adobe Photoshop CS6 > Plug-Ins > Panels.  

4. Restart Photoshop 
5. Click through the menu commands:  Window > Extensions > TK to open the 

panel in Photoshop. 
 
 
Installation for Photoshop CC starts on next page 
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Installation in Photoshop CC  
 
Installing the TK mini panel requires copying the "TK" folder in the download to the 
proper location on your hard drive.  Here is how to do it. 
 
1.  Quit Photoshop.  For Mac users that means right-clicking the tray icon for 
Photoshop and selecting "Quit" from the pop-up menu. 
 
2.  Locate the "TK" folder in the download as follows:  Download folder > 
"Installation-for-Photoshop-CC" folder > "TK" folder. 
 
3.  Find (or create) the correct destination folder on your hard drive.  The 
correct destination varies with your version of Photoshop CC. 
 
For Photoshop CC 2014/2015 the path to the destination folder is: 
 
Windows:  C:\Program Files (x86)\Common Files\Adobe\CEP\extensions 
 
Mac:  Macintosh HD/Library/Application Support/Adobe/CEP/extensions   
 
The "CEP" and "extensions" folders might be missing from the path listed above if 
they have not previously been required by Photoshop.  If they are not present, 
make them. 
 
a)  Create a "CEP" folder in the "Adobe" folder, and 
b)  Create an "extensions" folder in the "CEP" folder. 
 
It's very important to get this path correct, including the uppercase and lowercase 
letters.  You can copy and paste the folder names from above if need be, but do 
NOT include the quotation marks.  Once the correct path has been found or 
created, move onto Step 4. 
 
For Photoshop CC the path to the destination folder is: 
 
Windows:   
C:\Program Files (x86)\Common Files\Adobe\CEPServiceManager4 \extensions 
 
Mac:   
Macintosh HD/Library/Application Support/Adobe/CEPServiceManager4/extensions   
 
 
4. Copy the "TK" folder from the download folder to the correct 
"extensions" destination folder.  Do not open the "TK" folder and copy the 
contents.  Copy the entire "TK" folder to the "extensions" folder. 
 
5.  Open Photoshop and click through the menu item Window > Extensions 
> TK to open the panel. 
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USING THE THE PANEL 
 

 
There are only six buttons on the mini panel, so it's pretty easy 
to use. 
 
+/- All Masks−The first click puts all the Lights, Darks, and 
Midtones luminosity masks on the Channels panel.  The second 
click removes them. 
 
+/- Lights−The first click puts the Lights luminosity masks on 
the Channels panel.  The second click removes them. 
 
+/- Darks−The first click puts the Darks luminosity masks on 
the Channels panel.  The second click removes them. 

 
+/- Midtones−The first click puts the Midtone luminosity masks on the Channels 
panel.  The second click removes them. 
 
©Tony Kuyper−Opens a window with copyright information 
 
Online Support−Opens a browser window in the computer's default browser to a 
webpage on my website.  There are links there for additional information about 
luminosity masks and how to use them. 
 
The 16-bit luminosity masks placed on the Channels panel are only the starting 
point for using them.  These masks can be loaded as selections or incorporated into 
layer masks on adjustment layers to target the adjustments to specific tonal 
ranges.  Exposure-blending, luminosity painting, mask painting, and adjustments 
targeted to specific tones are some of the many ways to use luminosity masks.  The 
tutorials section on my website has several ideas for getting started. 
 
 
 
 
TROUBLESHOOTING 
 
The panel has been tested on Mac and Windows.  Because of the necessity to 
support previous versions of Photoshop, there is now a Flash-based version of the 
panel for Photoshop CS6 and an HTML5-based version for Photoshop CC.  Both 
versions have the same layout and buttons and both produce the same results.  
While they look slightly different, they do exactly the same thing.   
 
There are occasionally unexpected problems when using the panel.  A couple of the 
most common problems and possible solutions are listed starting on the next page.  
If you have other problems, please contact me and I'll try to help.   
 
 
 

http://goodlight.us/writing/tutorials.html
http://goodlight.us/contact.html
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1.  The panel has been installed but it doesn't show up in Photoshop.   
 
There are a few possibilities to consider here.   
 
a)  Make sure to click through the menu command Window >Extensions > TK to 
actually open the panel in Photoshop.  Installation is not enough to actually open 
the panel in Photoshop.  The menu command is needed.  Once the panel is open it 
will stay open and can be docked to a panel bar.   
 
b)  For Windows users using Photoshop CS6, there are actually two versions of 
Photoshop installed on the computer, a 32-bit version and a 64-bit version.  If the 
"TK" folders has been copied to the "Panels" folder of your application but doesn't 
show up under Window > Extensions, it often means you are running the other 
version of Photoshop.  Check the menu command Help > About Photoshop.  It will 
tell you if you are running the 32- or 64-bit version of the program.  Make sure you 
copy the "TK" folder to the "Panels" folder of the version of Photoshop (32-bit or 
62-bit) that you are running. 
 
c)  There is a preference setting that needs to be checked in order for extension 
panels to be loaded.  The check box "Load Extensions Panel" under the "Plug-Ins" 
preferences needs to be checked (red box, image below).   
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2.  The masks generate by the panel are inverted (the "Lights" masks are 
negatives and the "Dark" masks are positives). 

 
This is not a problem caused 
by the panel.  If you create 
a selection using one of the 
Photoshop's other selection 
tools and then save the 
selection as a mask, it will 
also be inverted.  So this is 
a Photoshop problem.  
There are two possible 
solutions.  
 
a)  Double-click the Edit in 
Quick Mask Mode button 
(rectangle with a circle 
inside) near the bottom of 
the Tools panel.  From the 
pop-up window, make sure 
the radio button for 
"Masked Areas" is selected.  
If the "Selected Areas" radio 
button is selected, masks 
will be inverted.   
 
b)  If the first solution 
doesn't work, it's possible 
the Photoshop "Preferences" 
file is corrupted and needs 
to be reset.  An online video 
to help do this can be found 
here.  
 
 
 
 
 
 
 

 
 
 
I hope the panel is useful to you and that it helps you achieve your artistic goals in 
Photoshop.  Please feel free to contact me if you have any questions, problems, or 
suggestions. 

http://helpx.adobe.com/photoshop/using/preferences.html
mailto:tony.kuyper@hotmail.com

